Long variable names are great for software maintainability.   Not many of us still use an archaic editor such as VIM or EMACS on a tiny screen where code size is a problem.

The following variable conveys no information to the reader, so the original author helpfully added a comment.

// column count
int c;

Choosing a better name for the variable means the comment is no longer required.

int columnCount;

So expand variable names at every opportunity where it will add some clarity to the code.

blog comments powered by Disqus